Supported Browsers for LEAP as of Polaris 6.2 Upgrade

Home > Articles > Supported Browsers for LEAP as of Polaris 6.2 Upgrade

As of the Polaris 6.2 upgrade, Internet Explorer, Safari, and Chrome are the only browsers that are supported for use with LEAP. 

In the past, we had recommended using Firefox to get around LEAP receipt printing issues in Google Chrome.  These issues have been resolved in the 6.2 version of LEAP. 

Between a host of other issues that occur using LEAP 6.2 in Firefox as well as it not being listed as a supported browser in official documentation, we can no longer recommend its use. 

If you are using Firefox and run into problems with LEAP, please switch to a supported browser.