Windows 7 Polaris Prerequisites

Home > Support > Documentation > Windows 7 Polaris Prerequisites

Please note that as of January 14, 2020, Windows 7 is no longer supported by Microsoft.  We highly recommend upgrading to Windows 8.1 or 10, as future updates may cause problems connecting to Polaris using Windows 7, and there may not be a fix readily available if/when this occurs. 

Once your computer has been updated you will also need to download and install the following: